Laverda OR600 Atlas

International Laverda Atlas Owners Registry
 
HomeHome  GalleryGallery  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  

Share | 
 

 problems with electric circuit

View previous topic View next topic Go down 
AuthorMessage
willem




PostSubject: problems with electric circuit   Fri Sep 24, 2010 1:54 pm

Hello!
After a long time started up my atlas, did some maintenance and fixed my broken airbox and replaced the airintake hose(?).The engine runs ok. But now te following problem.........no lights.....no traffik indicators.....checked everything........but when I turn on the light the engine stops.....so somekind of electrical breakdown....

Did someone had the same problems?

Please let me know how to fix it!!!

Greetz

Willem
Back to top Go down
View user profile
Nick

avatar


PostSubject: Re: problems with electric circuit   Fri Sep 24, 2010 5:14 pm

I guess it all worked OK before you stopped using it?

If it was OK before and not now after a long time just standing I'd be inclined to check the earth connections to the frame. These can become corroded over time.

On my Mk 2 model the main earth seemed to be located under the top frame tube at the junction with the tubes running down to the swinging arm. The loom (earth) is bolted to the frame here by a 10mm bolt. Try undoing this and cleaning the connections and frame with emery paper to remove any rust or discolouration on the connectors.

Nick :-)
Back to top Go down
View user profile
willem




PostSubject: Re: problems with electric circuit   Fri Sep 24, 2010 6:25 pm

Well thanks Nick,
That's a quick answer today!I'll try to locate and clean it!I hope that's the problem...............

Willem
Back to top Go down
View user profile
FRRRanky

avatar


PostSubject: Re: problems with electric circuit   Tue Sep 28, 2010 12:57 am

willem wrote:
Well thanks Nick,
That's a quick answer today!I'll try to locate and clean it!I hope that's the problem...............

Willem

This seems to be rather a short circuit in the electric light cables or switches or maybe a wrong contact between light and engine kill switch. With a voltmeter, it'll be not so difficult to find the origin.

Franky
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: problems with electric circuit   

Back to top Go down
 
problems with electric circuit
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Carver Cascade problems
» electric start on ktm 250 xcf-w
» Power Seats/Power Mirrors Fuse/Circuit Breaker
» electric start on 450 exc r 2010
» ELECTRIC SCREEN NOT WORKING

Permissions in this forum:You cannot reply to topics in this forum
Laverda OR600 Atlas :: All About Atlas :: Technics-
Jump to: